mirror of
https://gitlab.univ-nantes.fr/glicid-public/guix-glicid.git
synced 2025-04-30 06:08:37 +02:00
suppressing iana download
This commit is contained in:
parent
04d48042bc
commit
98f4e658a4
3 changed files with 12 additions and 236003 deletions
File diff suppressed because it is too large
Load diff
|
@ -1,22 +0,0 @@
|
||||||
diff --git a/src/plugins/lanplus/lanplus_crypt_impl.c b/src/plugins/lanplus/lanplus_crypt_impl.c
|
|
||||||
index d5fac37..8bb1879 100644
|
|
||||||
--- a/src/plugins/lanplus/lanplus_crypt_impl.c
|
|
||||||
+++ b/src/plugins/lanplus/lanplus_crypt_impl.c
|
|
||||||
@@ -164,7 +164,7 @@ lanplus_encrypt_aes_cbc_128(const uint8_t * iv,
|
|
||||||
uint8_t * output,
|
|
||||||
uint32_t * bytes_written)
|
|
||||||
{
|
|
||||||
- EVP_CIPHER_CTX ctx;
|
|
||||||
+ EVP_CIPHER_CTX *ctx = NULL;
|
|
||||||
EVP_CIPHER_CTX_init(&ctx);
|
|
||||||
EVP_EncryptInit_ex(&ctx, EVP_aes_128_cbc(), NULL, key, iv);
|
|
||||||
EVP_CIPHER_CTX_set_padding(&ctx, 0);
|
|
||||||
@@ -239,7 +239,7 @@ lanplus_decrypt_aes_cbc_128(const uint8_t * iv,
|
|
||||||
uint8_t * output,
|
|
||||||
uint32_t * bytes_written)
|
|
||||||
{
|
|
||||||
- EVP_CIPHER_CTX ctx;
|
|
||||||
+ EVP_CIPHER_CTX *ctx = NULL;
|
|
||||||
EVP_CIPHER_CTX_init(&ctx);
|
|
||||||
EVP_DecryptInit_ex(&ctx, EVP_aes_128_cbc(), NULL, key, iv);
|
|
||||||
EVP_CIPHER_CTX_set_padding(&ctx, 0);
|
|
|
@ -0,0 +1,12 @@
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index b421192..eb4f232 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -60,6 +60,7 @@ if test "x$WGET" = "x"; then
|
||||||
|
if test "x$CURL" = "x"; then
|
||||||
|
AC_MSG_WARN([** Neither wget nor curl could be found.])
|
||||||
|
AC_MSG_WARN([** IANA PEN database will not be installed by `make install` !])
|
||||||
|
+ DOWNLOAD=""
|
||||||
|
else
|
||||||
|
DOWNLOAD="$CURL --location --progress-bar"
|
||||||
|
AM_CONDITIONAL([DOWNLOAD], [true])
|
Loading…
Add table
Reference in a new issue