mirror of
https://gitlab.univ-nantes.fr/glicid-public/guix-glicid.git
synced 2025-04-29 21:58:36 +02:00
patch was empty
This commit is contained in:
parent
43e99b3c4a
commit
d0bceb94b9
1 changed files with 85 additions and 0 deletions
|
@ -0,0 +1,85 @@
|
||||||
|
diff --git a/Cargo.lock b/Cargo.lock
|
||||||
|
index 311fa43b..672febf6 100644
|
||||||
|
--- a/Cargo.lock
|
||||||
|
+++ b/Cargo.lock
|
||||||
|
@@ -4488,20 +4488,20 @@ dependencies = [
|
||||||
|
"synstructure",
|
||||||
|
]
|
||||||
|
|
||||||
|
-[[package]]
|
||||||
|
-name = "yubico"
|
||||||
|
-version = "0.12.0"
|
||||||
|
-source = "git+https://github.com/BlackDex/yubico-rs?rev=00df14811f58155c0f02e3ab10f1570ed3e115c6#00df14811f58155c0f02e3ab10f1570ed3e115c6"
|
||||||
|
-dependencies = [
|
||||||
|
- "base64 0.22.1",
|
||||||
|
- "form_urlencoded",
|
||||||
|
- "futures",
|
||||||
|
- "hmac",
|
||||||
|
- "rand",
|
||||||
|
- "reqwest",
|
||||||
|
- "sha1",
|
||||||
|
- "threadpool",
|
||||||
|
-]
|
||||||
|
+#[[package]]
|
||||||
|
+#name = "yubico"
|
||||||
|
+#version = "0.12.0"
|
||||||
|
+#source = "git+https://github.com/BlackDex/yubico-rs?rev=00df14811f58155c0f02e3ab10f1570ed3e115c6#00df14811f58155c0f02e3ab10f1570ed3e115c6"
|
||||||
|
+#dependencies = [
|
||||||
|
+# "base64 0.22.1",
|
||||||
|
+# "form_urlencoded",
|
||||||
|
+# "futures",
|
||||||
|
+# "hmac",
|
||||||
|
+# "rand",
|
||||||
|
+# "reqwest",
|
||||||
|
+# "sha1",
|
||||||
|
+# "threadpool",
|
||||||
|
+#]
|
||||||
|
|
||||||
|
[[package]]
|
||||||
|
name = "zerocopy"
|
||||||
|
diff --git a/Cargo.toml b/Cargo.toml
|
||||||
|
index f739145b..4561b182 100644
|
||||||
|
--- a/Cargo.toml
|
||||||
|
+++ b/Cargo.toml
|
||||||
|
@@ -13,7 +13,7 @@ publish = false
|
||||||
|
build = "build.rs"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-# default = ["sqlite"]
|
||||||
|
+default = ["sqlite"]
|
||||||
|
# Empty to keep compatibility, prefer to set USE_SYSLOG=true
|
||||||
|
enable_syslog = []
|
||||||
|
mysql = ["diesel/mysql", "diesel_migrations/mysql"]
|
||||||
|
@@ -106,7 +106,9 @@ jsonwebtoken = "9.3.0"
|
||||||
|
totp-lite = "2.0.1"
|
||||||
|
|
||||||
|
# Yubico Library
|
||||||
|
-yubico = { version = "0.12.0", features = ["online-tokio"], default-features = false }
|
||||||
|
+#yubico = { version = "0.12.0", features = ["online-tokio"], default-features = false }
|
||||||
|
+#yubico = { version = "0.12.0", default-features = true }
|
||||||
|
+yubico = { version = "0.11.0", default-features = true }
|
||||||
|
|
||||||
|
# WebAuthn libraries
|
||||||
|
webauthn-rs = "0.3.2"
|
||||||
|
@@ -136,7 +138,7 @@ bytes = "1.9.0"
|
||||||
|
cached = { version = "0.54.0", features = ["async"] }
|
||||||
|
|
||||||
|
# Used for custom short lived cookie jar during favicon extraction
|
||||||
|
-cookie = "0.18.1"
|
||||||
|
+cookie = "0.18.0" ## YD was 0.18.1
|
||||||
|
cookie_store = "0.21.1"
|
||||||
|
|
||||||
|
# Used by U2F, JWT and PostgreSQL
|
||||||
|
@@ -166,9 +168,9 @@ rpassword = "7.3.1"
|
||||||
|
# Loading a dynamic CSS Stylesheet
|
||||||
|
grass_compiler = { version = "0.13.4", default-features = false }
|
||||||
|
|
||||||
|
-[patch.crates-io]
|
||||||
|
-# Patch yubico to remove duplicate crates of older versions
|
||||||
|
-yubico = { git = "https://github.com/BlackDex/yubico-rs", rev = "00df14811f58155c0f02e3ab10f1570ed3e115c6" }
|
||||||
|
+##[patch.crates-io]
|
||||||
|
+### Patch yubico to remove duplicate crates of older versions
|
||||||
|
+##yubico = { git = "https://github.com/BlackDex/yubico(-rs", rev = "00df14811f58155c0f02e3ab10f1570ed3e115c6" }
|
||||||
|
|
||||||
|
# Strip debuginfo from the release builds
|
||||||
|
# The symbols are the provide better panic traces
|
Loading…
Add table
Reference in a new issue